We are completing our planned upgrades and restarting reporting shortly.
Posted Oct 01, 2025 - 01:13 PDT
Update
We are currently upgrading our click reporting to support enhanced bot filtering, which requires pausing our reporting systems to apply our changes. You may see delays in your reports but click data will not be lost during this time. This change should only take a couple of hours and reporting will be re-enabled shortly.
Posted Sep 30, 2025 - 17:02 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 30, 2025 - 17:00 PDT
Update
We are currently upgrading our click reporting to support enhanced bot filtering, which requires pausing our reporting systems to apply our changes. You may see delays in your reports but click data will not be lost during this time. This change should only take a couple of hours and reporting will be re-enabled shortly.
Posted Sep 30, 2025 - 16:43 PDT
Scheduled
We are currently upgrading our click reporting to support enhanced bot filtering, which requires pausing our reporting systems to apply our changes. You may see delays in your reports but click data will not be lost during this time. This change should only take a couple of hours and reporting will be re-enabled shortly.