Issue with Credit Card Processing
Incident Report for Geniuslink
Resolved
This incident has been resolved. All Invoices for usage in December 2022 have been generated, and will be charged on Jan 25th 2023.
Posted Jan 05, 2023 - 09:41 PST
Investigating
We have been alerted to an issue in our regularly scheduled billing cycle that has caused some payments to fail even though a valid card is on file. Please ignore any failed Payment emails that you may have received. We are currently investigating and will update as soon as we learn more.
Posted Jan 03, 2023 - 10:54 PST