Reporting data may be lagging behind.
Incident Report for Geniuslink
Resolved
This incident has been resolved.
Posted Mar 16, 2022 - 09:01 PDT
Monitoring
Reporting data may be lagging behind a bit, as database is refreshed. Clicks are still being recorded properly, but display data in the dashboard may temporarily not appear in real-time.
Posted Mar 15, 2022 - 20:24 PDT
This incident affected: Real-time Link Optimization.