Amazon product API issues causing link health over-reporting and localization inconsistency

Incident Report for Geniuslink

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 14:40 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 06, 2026 - 09:03 PST

Investigating

We are currently investigating this issue. Note that you may notice your link health reports showing incorrect and overly abundant status messages while this issue persists. In addition, we've received reports that the link localization is showing incorrect information during link creation and editing, and may be affecting localization in some cases.
Posted Feb 06, 2026 - 06:59 PST
This incident affected: Product Matching API.