Proxy link processing issues.
Incident Report for Geniuslink
Postmortem

On July 31st at 9AM PST we deployed an update to our click processing service to one of our regional data centers for testing. The following day, August 1st, this was deployed out to the remainder of our servers all around the world. Early in the morning on August 3rd it was discovered that this deployment was impacting our Proxy link processing, which was causing all clicks to Javascript snippet, Plugin, or Quickbuild links to fail to be processed through our service and simply default back to the original destination. Additionally this resulted in clicks not being reported inside of the Geniuslink dashboard.

This incident had no impact on any shortened/manually built geni.us links, and all short links continued to be automatically localized and affiliated through our service as they should be. However, this did result in a minor visual bug in our Global visualizer inside of the dashboard, which was incorrectly showing “no local match” for all countries.

This issue has been fully resolved as of 10:30AM PST on August 3, 2023, and clicks to all Proxy links (JS Snippet, Plugin, and Quickbuild) are being processed through our service once more.

Posted Aug 03, 2023 - 14:28 PDT

Resolved
At 10AM PST Aug 3, 2023, we discovered an issue with our Proxy link format, which impacted Amazon Link Engine Plugin, JS Snippet, and Quickbuild links run through our service. This issue caused these links to fail to be processed by our service, defaulting back to the original url. The deployment that caused this issue was rolled back, and all links were back to functional as of 10:30AM PST Aug 3, 2023.
Posted Aug 03, 2023 - 09:30 PDT