Temporary Reporting Lag
Incident Report for Geniuslink
Resolved
Reporting has all been caught up as of 11:30PM PST.
Posted Sep 21, 2022 - 09:22 PDT
Investigating
There is currently a slight reporting lag due to infrastructure deployments. We will update once reports have been caught back up.
Posted Sep 20, 2022 - 16:46 PDT
This incident affected: Metrics.