Partial click processing outage.
Incident Report for Geniuslink
Resolved
The issues with the upstream provider have been resolved by their team and everything is fully operational again for Geniuslink as of 3:51PM PST.
Posted Sep 13, 2023 - 15:55 PDT
Investigating
There appears to be an issue with one of our hosting providers in San Francisco that is causing intermittent click processing issues for some customers. Our engineers are investigating and we will work to resolve things as soon as possible.
Posted Sep 13, 2023 - 13:48 PDT
This incident affected: Links.