Resolved: Traffic reporting under maintenance

Incident Report for Geniuslink

Resolved

This incident is resolved.
Posted Oct 02, 2025 - 10:32 PDT

Monitoring

We've finished maintenance on the traffic reporting system and click reporting from September 30 on is resumed. Note: Click counts may appear lower on Oct 1 due to improved bot filtering.
Posted Oct 01, 2025 - 20:30 PDT

Investigating

Our rollout of new bot detection didn't go as smoothly as expected and we are still working on the upgrade. In the meantime, traffic reports will not show clicks since September 30. We continue to work on it and hope to have things running today.
Posted Oct 01, 2025 - 07:31 PDT
This incident affected: Metrics.